Site Overlay

QinQ

QinQ分为两种:
1、基本QinQ,也叫做普通QinQ。是基于接口实现的,即对该接口收到的所有报文,都加上一层VLAN Tag。

2、灵活QinQ,也叫做VLAN Stacking。是基于接口和VLAN实现的,即对该接口收到的与指定VLAN相匹配的报文,才会再加上一层VLAN Tag 。

应用场景:
公司A要求接入运营商的网络;
运营商为公司A分配的VLAN是1000;
公司A的各个部门,分别属于不同的VLAN10和VLAN30。

配置思路:
在PE设备连接公司A的接口GE0/0/1上,配置基本QinQ功能,使PE对收到的公司A的所有报文都加一层VLAN 为1000的Tag。
CE设备不需要修改任何配置 。

基本QinQ的配置步骤

1、创建VLAN 1000
<PE> system-view
[PE] vlan batch 1000

2、配置GE0/0/1接口的基本QinQ功能
[PE] interface gigabitethernet 0/0/1
[PE-GigabitEthernet0/0/1] port link-type dot1q-tunnel
[PE-GigabitEthernet0/0/1] port default vlan 1000
[PE-GigabitEthernet0/0/1] quit

3、配置上行GE0/0/2接口透传VLAN1000
[PE] interface gigabitethernet 0/0/2
[PE-GigabitEthernet0/0/2] port link-type trunk
[PE-GigabitEthernet0/0/2] port trunk allow-pass vlan 1000
[PE-GigabitEthernet0/0/2] quit

灵活QinQ的应用场景

应用场景:
两个公司A和B分布在不同的区域;
公司A和公司B的数据业务在VLAN10内通信,
语音业务在VLAN 30内通信;
运营商希望两个公司接入运营商网络时,数据业务使用VLAN100进行通信,语音业务使用VLAN 30进行通信;
要求在不更改公司A和公司B的现有配置情况下,实现公司A和公司B数据业务和语音业务的正常通信。

配置思路:
在PE设备上配置灵活QinQ功能,使数据业务在透传运营商网络时,使用VLAN100进行通信。
在PE设备上直接透传语音业务对应的VLAN30。

灵活QinQ的配置步骤

1、创建VLAN 30和VLAN100
<PE> system-view
[PE] vlan batch 30 100

2、配置GE0/0/1接口的灵活QinQ功能
[PE] interface gigabitethernet 0/0/1
[PE-GigabitEthernet0/0/1] port link-type hybrid
[PE-GigabitEthernet0/0/1] qinq vlan-translation enable
[PE-GigabitEthernet0/0/1] port vlan-stacking vlan 10 stack-vlan 100
[PE-GigabitEthernet0/0/1] port hybrid untagged vlan 100

3、配置GE0/0/1接口的透传语音业务对应的VLAN 30
[PE-GigabitEthernet0/0/1] port hybrid tagged vlan 30
[PE-GigabitEthernet0/0/1] port vlan-mapping vlan 30 map-vlan 30
[PE-

4、配置上行GE0/0/2接口,透传VLAN30和VLAN100
[PE] interface gigabitethernet 0/0/2
[PE-GigabitEthernet0/0/2] port link-type trunk
[PE-GigabitEthernet0/0/2] port trunk allow-pass vlan 30 100
[PE-GigabitEthernet0/0/2] quit

 

 

Author: 伍小虎

向各位朋友学习。 鄙人从事:信息化系统(光缆熔接、虚拟化、网络安全等);智能化系统(楼宇对讲系统、智能照明系统、综合布线系统、智能家居系统等);安全技术防范系统(视频监控系统、防盗报警系统、门禁管理系统、停车场管理系统、门客访问系统等)欢迎带项目咨询。

发表评论